Main page
OID Repository
https://oid-base.com
Display OID:

{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) docsDev(69) docsDevMIBObjects(1) docsDevEvent(5) docsDevEvControlTable(7) docsDevEvControlEntry(1) docsDevEvReporting(2)}

docsDevEvReporting(2)

 
 

OID description



   
OID: (ASN.1 notation)
(dot notation)
(OID-IRI notation)

Description:

docsDevEvReporting OBJECT-TYPE
SYNTAX BITS {
local(0),
traps(1),
syslog(2),
-- The following are extensions to the original set of
-- labels. The extensions start at an octet boundary.
-- So for bits 3 - 7, one MUST set them to zero on send
-- and one MUST ignore them on receipt.
localVolatile(8),
stdInterface(9)}
MAX-ACCESS read-write
STATUS current
DESCRIPTION
"Defines the action to be taken on occurrence of this event class. Implementations may not necessarily support all options for all event classes but at minimum must allow traps and syslogging to be disabled.
If the local(0) bit is set, then log to the internal log and update non-volatile store, for backward compatibility with the original RFC 2669 definition.
If the traps(1) bit is set, then generate an SNMP trap; if the syslog(2) bit is set, then send a syslog message (assuming that the syslog address is set). If the localVolatile(8) bit is set, then log to the internal log without updating non-volatile store. If the stdInterface(9) bit is set, then the agent ignores all other bits except the local(0), syslog(2), and localVolatile(8) bits. Setting the
stdInterface(9) bit indicates that RFC3413 and RFC3014 are being used to control event reporting mechanisms."



Information:

Automatically extracted from IETF RFC 4639.

 
 
Short link:


Parent OID: docsDevEvControlEntry(1) First sibling OID: docsDevEvPriority(1) Previous sibling OID: docsDevEvPriority(1)