Main page
OID Repository
https://oid-base.com
Display OID:

{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) rmon(16) interfaceTopNMIB(27) interfaceTopNObjects(1) interfaceTopNControlTable(2) interfaceTopNControlEntry(1) interfaceTopNObjectVariable(2)}

interfaceTopNObjectVariable(2)

 
 

OID description



 
OID: (ASN.1 notation)
(dot notation)
(OID-IRI notation)

Description:

interfaceTopNObjectVariable OBJECT-TYPE
SYNTAX INTEGER {
ifInOctets(0),
ifInUcastPkts(1),
ifInNUcastPkts(2),
ifInDiscards(3),
ifInErrors(4),
ifInUnknownProtos(5),
ifOutOctets(6),
ifOutUcastPkts(7),
ifOutNUcastPkts(8),
ifOutDiscards(9),
ifOutErrors(10),
ifInMulticastPkts(11),
ifInBroadcastPkts(12),
ifOutMulticastPkts(13),
ifOutBroadcastPkts(14),
ifHCInOctets(15),
ifHCInUcastPkts(16),
ifHCInMulticastPkts(17),
ifHCInBroadcastPkts(18),
ifHCOutOctets(19),
ifHCOutUcastPkts(20),
ifHCOutMulticastPkts(21),
ifHCOutBroadcastPkts(22),
dot3StatsAlignmentErrors(23),
dot3StatsFCSErrors(24),
dot3StatsSingleCollisionFrames(25),
dot3StatsMultipleCollisionFrames(26),
dot3StatsSQETestErrors(27),
dot3StatsDeferredTransmissions(28),
dot3StatsLateCollisions(29),
dot3StatsExcessiveCollisions(30),
dot3StatsInternalMacTxErrors(31),
dot3StatsCarrierSenseErrors(32),
dot3StatsFrameTooLongs(33),
dot3StatsInternalMacRxErrors(34),
dot3StatsSymbolErrors(35),
dot3InPauseFrames(36),
dot3OutPauseFrames(37),
dot5StatsLineErrors(38),
dot5StatsBurstErrors(39),
dot5StatsACErrors(40),
dot5StatsAbortTransErrors(41),
dot5StatsInternalErrors(42),
dot5StatsLostFrameErrors(43),
dot5StatsReceiveCongestions(44),
dot5StatsFrameCopiedErrors(45),
dot5StatsTokenErrors(46),
dot5StatsSoftErrors(47),
dot5StatsHardErrors(48),
dot5StatsSignalLoss(49),
dot5StatsTransmitBeacons(50),
dot5StatsRecoverys(51),
dot5StatsLobeWires(52),
dot5StatsRemoves(53),
dot5StatsSingles(54),
dot5StatsFreqErrors(55),
etherStatsDropEvents(56),
etherStatsOctets(57),
etherStatsPkts(58),
etherStatsBroadcastPkts(59),
etherStatsMulticastPkts(60),
etherStatsCRCAlignErrors(61),
etherStatsUndersizePkts(62),
etherStatsOversizePkts(63),
etherStatsFragments(64),
etherStatsJabbers(65),
etherStatsCollisions(66),
etherStatsPkts64Octets(67),
etherStatsPkts65to127Octets(68),
etherStatsPkts128to255Octets(69),
etherStatsPkts256to511Octets(70),
etherStatsPkts512to1023Octets(71),
etherStatsPkts1024to1518Octets(72),
dot1dTpPortInFrames(73),
dot1dTpPortOutFrames(74),
dot1dTpPortInDiscards(75)
}
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"The particular variable to be sampled.
Values between 0 and 22, point to MIB objects defined in
IF-MIB [RFC2863].
Values between 23 and 37, point to MIB objects defined in
EtherLike-MIB [RFC2665].
Values between 38 and 55, point to MIB objects defined in
TOKENRING-MIB [RFC1748].
Values between 56 and 72, point to MIB objects defined in
RMON-MIB [RFC2819].
Values between 73 and 75, point to MIB objects defined in
BRIDGE-MIB [RFC1493].
Because SNMP access control is articulated entirely in terms
of the contents of MIB views, no access control mechanism
exists that can restrict the value of this object to identify
only those objects that exist in a particular MIB view.
Because there is thus no acceptable means of restricting the
read access that could be obtained through the TopN
mechanism, the probe must only grant write access to this
object in those views that have read access to all objects on
the probe.
During a set operation, if the supplied variable name is not
available in the selected MIB view, or does not conform the
other conditions mentioned above, a badValue error must be
returned.
This object may not be modified if the associated
interfaceTopNControlStatus object is equal to active(1)."



Classification:

MIB object for network management

 
See classes of OIDs

Information:

Automatically extracted from IETF RFC 3144.


Note to implementers:




 
 
Short link:


Parent OID: interfaceTopNControlEntry(1) First sibling OID: interfaceTopNControlIndex(1) Previous sibling OID: interfaceTopNControlIndex(1) Next sibling OID: interfaceTopNObjectSampleType(3) Last sibling OID: interfaceTopNRowStatus(13)