---
oid: "1.3.6.1.2.1.82"
short-description: "lookupMIB MODULE-IDENTITY"
last-modified: "2021-09-02"
parent-oid: "1.3.6.1.2.1"
---

## OID: `1.3.6.1.2.1.82`

```asn1
{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) lookupMIB(82)}
```

### Description

```asn1
lookupMIB MODULE-IDENTITY
LAST-UPDATED "200606130000Z" -- 13 June 2006
ORGANIZATION "IETF Distributed Management Working Group"
CONTACT-INFO
"Juergen Quittek
NEC Europe Ltd.
Network Laboratories
Kurfuersten-Anlage 36
69115 Heidelberg
Germany
Phone: +49 6221 4342-115
Email: quittek@netlab.nec.de"
DESCRIPTION
"The Lookup MIB (DISMAN-NSLOOKUP-MIB) enables determination
of either the name(s) corresponding to a host address or of
the address(es) associated with a host name at a remote
host.
Copyright (C) The Internet Society (2006). This version of
this MIB module is part of RFC 4560; see the RFC itself for
full legal notices."
\-- Revision history
REVISION "200606130000Z" -- 13 June 2006
DESCRIPTION
"Updated version, published as RFC 4560.
- Replaced references to RFC 2575 by RFC 3415
- Replaced references to RFC 2571 by RFC 3411
- Replaced references to RFC 2851 by RFC 4001
- Added value enabled(1) to SYNTAX clause of
lookupCtlOperStatus
- Added lookupMinimumCompliance
- Defined semantics of value 0 for object
lookupPurgeTime
- Added DEFVAL { unknown } to object
lookupCtlTargetAddressType OBJECT-TYPE"
REVISION "200009210000Z" -- 21 September 2000
DESCRIPTION
"Initial version, published as RFC 2925."
```

**Classification:** MIB object for network management; Module in a given formal language

### Supplementary information

Automatically extracted from IETF [RFC 4560](https://www.rfc-editor.org/rfc/rfc4560.html).

### Child OIDs

- `1.3.6.1.2.1.82.1`: `lookupObjects(1)`
- `1.3.6.1.2.1.82.2`: `lookupConformance(2)`

### Terms of Use

[Terms of use](https://oid-base.com/disclaimer.htm.md)

**Note to implementers:**: The OID repository is constantly updated but does not necessarily store the latest (or most accurate) version of this formal description. For an implementation, it is recommended to search the web for a more recent description. If this is the case, please update the above description.
