---
oid: "1.3.6.1.2.1.80.1.2.1.22"
short-description: "pingCtlDSField OBJECT-TYPE"
last-modified: "2021-09-02"
parent-oid: "1.3.6.1.2.1.80.1.2.1"
---

## OID: `1.3.6.1.2.1.80.1.2.1.22`

```asn1
{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) pingMIB(80) pingObjects(1) pingCtlTable(2) pingCtlEntry(1) pingCtlDSField(22)}
```

### Description

```asn1
pingCtlDSField OBJECT-TYPE
SYNTAX Unsigned32 (0..255)
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"Specifies the value to store in the Type of Service
(TOS) octet in the IPv4 header or in the Traffic
Class octet in the IPv6 header, respectively, of the
IP packet used to encapsulate the ping probe.
The octet to be set in the IP header contains the
Differentiated Services (DS) Field in the six most
significant bits.
This option can be used to determine what effect an
explicit DS Field setting has on a ping response.
Not all values are legal or meaningful. A value of 0
means that the function represented by this option is
not supported. DS Field usage is often not supported
by IP implementations, and not all values are supported.
Refer to RFC 2474 and RFC 3260 for guidance on usage of
this field."
REFERENCE
"Refer to RFC 1812 for the definition of the IPv4 TOS
octet and to RFC 2460 for the definition of the IPv6
Traffic Class octet. Refer to RFC 2474 and RFC 3260
for the definition of the Differentiated Services Field."
DEFVAL { 0 }
```

**Classification:** MIB object for network management

### Supplementary information

Automatically extracted from IETF [RFC 4560](https://www.rfc-editor.org/rfc/rfc4560.html).

### Child OIDs

No child OID

### Terms of Use

[Terms of use](https://oid-base.com/disclaimer.htm.md)

**Note to implementers:**: The OID repository is constantly updated but does not necessarily store the latest (or most accurate) version of this formal description. For an implementation, it is recommended to search the web for a more recent description. If this is the case, please update the above description.
