---
oid: "1.3.6.1.2.1.80"
short-description: "pingMIB MODULE-IDENTITY"
last-modified: "2021-09-02"
parent-oid: "1.3.6.1.2.1"
---

## OID: `1.3.6.1.2.1.80`

```asn1
{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) pingMIB(80)}
```

### Description

```asn1
pingMIB MODULE-IDENTITY
LAST-UPDATED "200606130000Z" -- 13 June 2006
ORGANIZATION "IETF Distributed Management Working Group"
CONTACT-INFO
"Juergen Quittek
NEC Europe Ltd.
Network Laboratories
Kurfuersten-Anlage 36
69115 Heidelberg
Germany
Phone: +49 6221 4342-115
Email: quittek@netlab.nec.de"
DESCRIPTION
"The Ping MIB (DISMAN-PING-MIB) provides the capability of
controlling the use of the ping function at a remote
host.
Copyright (C) The Internet Society (2006). This version of
this MIB module is part of RFC 4560; see the RFC itself for
full legal notices."
\-- Revision history
REVISION "200606130000Z" -- 13 June 2006
DESCRIPTION
"Updated version, published as RFC 4560.
- Correctly considered IPv6 in DESCRIPTION
clause of pingCtlDataSize
- Replaced references to RFC 2575 by RFC 3415
- Replaced references to RFC 2571 by RFC 3411
- Replaced references to RFC 2851 by RFC 4001
- Added DEFVAL { {} } to definition of
pingCtlTrapGeneration
- Changed DEFVAL of object pingCtlDescr from
DEFVAL { '00'H } to DEFVAL { ''H }
- Changed DEFVAL of object pingCtlSourceAddressType
from DEFVAL { ipv4 } to DEFVAL { unknown }
- Extended DESCRIPTION clause of pingResultsTable
describing re-initialization of entries
- Changed SYNTAX of pingResultsProbeResponses and
pingResultsSentProbes from Unsigned32 to Gauge32
- Changed status of pingCompliance to deprecated
- Added pingFullCompliance and pingMinimumCompliance
- Changed status of pingGroup and pingTimeStampGroup
to deprecated
- Added pingMinimumGroup, pingCtlRowStatusGroup,
and pingHistoryGroup"
REVISION "200009210000Z" -- 21 September 2000
DESCRIPTION
"Initial version, published as RFC 2925."
```

**Classification:** MIB object for network management; Module in a given formal language

### Supplementary information

Automatically extracted from IETF [RFC 4560](https://www.rfc-editor.org/rfc/rfc4560.html).

### Child OIDs

- `1.3.6.1.2.1.80.0`: `pingNotifications(0)`
- `1.3.6.1.2.1.80.1`: `pingObjects(1)`
- `1.3.6.1.2.1.80.2`: `pingConformance(2)`
- `1.3.6.1.2.1.80.3`: `pingImplementationTypeDomains(3)`

### Terms of Use

[Terms of use](https://oid-base.com/disclaimer.htm.md)

**Note to implementers:**: The OID repository is constantly updated but does not necessarily store the latest (or most accurate) version of this formal description. For an implementation, it is recommended to search the web for a more recent description. If this is the case, please update the above description.
