---
oid: "1.3.6.1.2.1.57"
short-description: "marsMIB MODULE-IDENTITY"
last-modified: "2020-06-23"
parent-oid: "1.3.6.1.2.1"
---

## OID: `1.3.6.1.2.1.57`

```asn1
{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) marsMIB(57)}
```

### Description

```asn1
marsMIB MODULE-IDENTITY
LAST-UPDATED "9809010000Z" -- 01 September 1998
ORGANIZATION "Internetworking Over NBMA (ion) Working Group"
CONTACT-INFO
"Chris Chung (chihschung@aol.com)
Independent Consultant
Editor: Maria Greene
Postal: Independent Contractor
E-mail: maria@xedia.com"
DESCRIPTION
"This module defines a portion of the managed information base (MIB) for managing classical IP multicast address resolution server (MARS) and related entities as described in the RFC2022. This MIB is meant to be used in conjunction with the ATM-MIB (RFC1695), MIB-II (RFC1213), and optionally the IF-MIB (RFC1573)."
REVISION "9809010000Z" -- 01 September 1998
DESCRIPTION "Published as RFC 2417. Changes/fixes:
- reroot this MIB from snmpModules to mib-2 to be consistent with location of other MIBs.
- obsoletes RFC2366."
REVISION "9804150145Z" -- 15 April 1998
DESCRIPTION "Initial version, published as RFC 2366"
```

**Classification:** MIB object for network management; Module in a given formal language

### Supplementary information

Automatically extracted from IETF [RFC 2417](https://www.rfc-editor.org/rfc/rfc2417.html).

### Child OIDs

- `1.3.6.1.2.1.57.0`: `marsTrapInfo(0)`
- `1.3.6.1.2.1.57.1`: `marsClientObjects(1)`
- `1.3.6.1.2.1.57.2`: `marsObjects(2)`
- `1.3.6.1.2.1.57.3`: `marsMcsObjects(3)`
- `1.3.6.1.2.1.57.4`: `marsConformance(4)`

### Terms of Use

[Terms of use](https://oid-base.com/disclaimer.htm.md)

**Note to implementers:**: The OID repository is constantly updated but does not necessarily store the latest (or most accurate) version of this formal description. For an implementation, it is recommended to search the web for a more recent description. If this is the case, please update the above description.
