---
oid: "1.3.6.1.2.1.185.2.1.6"
short-description: "mgmdIgmpV2MldV1RouterReadMIBCompliance MODULE-COMPLIANCE"
last-modified: "2020-07-08"
parent-oid: "1.3.6.1.2.1.185.2.1"
---

## OID: `1.3.6.1.2.1.185.2.1.6`

```asn1
{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) mgmdStdMIB(185) mgmdMIBConformance(2) mgmdMIBCompliance(1) mgmdIgmpV2MldV1RouterReadMIBCompliance(6)}
```

### Description

```asn1
mgmdIgmpV2MldV1RouterReadMIBCompliance MODULE-COMPLIANCE
STATUS current
DESCRIPTION
"A read-only compliance statement for routers running IGMPv2 [RFC2236] or MLDv1 [RFC2710] and implementing the MGMD MIB. IGMPv2 routers only support the IPv4 address type and MLDv1 routers only support the IPv6 address type."
MODULE -- this module
MANDATORY-GROUPS {mgmdRouterBaseMIBGroup, mgmdV2RouterBaseMIBGroup}
OBJECT mgmdRouterInterfaceLastMemberQueryInterval
MIN-ACCESS read-only
DESCRIPTION
"Write access is not required."
OBJECT mgmdRouterInterfaceRobustness
MIN-ACCESS read-only
DESCRIPTION
"Write access is not required."
OBJECT mgmdRouterInterfaceQueryMaxResponseTime
MIN-ACCESS read-only
DESCRIPTION
"Write access is not required."
OBJECT mgmdRouterInterfaceVersion
SYNTAX Unsigned32 (1..2)
MIN-ACCESS read-only
DESCRIPTION
"Write access is not required. Only versions 1 and 2 need to be supported."
OBJECT mgmdRouterInterfaceStatus
SYNTAX RowStatus {active(1)}
MIN-ACCESS read-only
DESCRIPTION
"Read-write or read-create access is not required and only the value 'active(1)' needs to be supported."
OBJECT mgmdRouterInterfaceQueryInterval
MIN-ACCESS read-only
DESCRIPTION
"Write access is not required."
GROUP mgmdV2ProxyMIBGroup
DESCRIPTION
"Write access is not required."
```

**Classification:** MIB object for network management

### Supplementary information

Automatically extracted from IETF [RFC 5519](https://www.rfc-editor.org/rfc/rfc5519.html).

### Child OIDs

No child OID

### Terms of Use

[Terms of use](https://oid-base.com/disclaimer.htm.md)

**Note to implementers:**: The OID repository is constantly updated but does not necessarily store the latest (or most accurate) version of this formal description. For an implementation, it is recommended to search the web for a more recent description. If this is the case, please update the above description.
