---
oid: "1.3.6.1.2.1.157.1.1.1.23"
short-description: "pimInterfaceStubInterface OBJECT-TYPE"
last-modified: "2020-01-17"
parent-oid: "1.3.6.1.2.1.157.1.1.1"
---

## OID: `1.3.6.1.2.1.157.1.1.1.23`

```asn1
{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) pimStdMIB(157) pim(1) pimInterfaceTable(1) pimInterfaceEntry(1) pimInterfaceStubInterface(23)}
```

### Description

```asn1
pimInterfaceStubInterface OBJECT-TYPE
SYNTAX TruthValue
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"Whether this interface is a 'stub interface'. If this
object is set to TRUE, then no PIM packets are sent out this
interface, and any received PIM packets are ignored.
Setting this object to TRUE is a security measure for
interfaces towards untrusted hosts. This allows an
interface to be configured for use with IGMP (Internet Group
Management Protocol) or MLD (Multicast Listener Discovery)
only, which protects the PIM router from forged PIM messages
on the interface.
To communicate with other PIM routers using this interface,
this object must remain set to FALSE.
Changing the value of this object while the interface is
operational causes PIM to be disabled and then re-enabled on
this interface."
REFERENCE "RFC 3376, RFC 3810"
DEFVAL { false }
```

**Classification:** MIB object for network management

### Supplementary information

Automatically extracted from IETF [RFC 5060](https://www.rfc-editor.org/rfc/rfc5060.html).

### Child OIDs

No child OID

### Terms of Use

[Terms of use](https://oid-base.com/disclaimer.htm.md)

**Note to implementers:**: The OID repository is constantly updated but does not necessarily store the latest (or most accurate) version of this formal description. For an implementation, it is recommended to search the web for a more recent description. If this is the case, please update the above description.
