---
oid: "1.3.6.1.2.1.118.1.2.3.1"
short-description: "alarmActiveVariableEntry OBJECT-TYPE"
last-modified: "2020-04-15"
parent-oid: "1.3.6.1.2.1.118.1.2.3"
---

## OID: `1.3.6.1.2.1.118.1.2.3.1`

```asn1
{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) alarmMIB(118) alarmObjects(1) alarmActive(2) alarmActiveVariableTable(3) alarmActiveVariableEntry(1)}
```

### Description

```asn1
alarmActiveVariableEntry OBJECT-TYPE
SYNTAX AlarmActiveVariableEntry
MAX-ACCESS not-accessible
STATUS current
DESCRIPTION
"Entries appear in this table when there are variables in
the varbind list of a corresponding alarm in
alarmActiveTable.
Entries appear in this table as though
the trap/notification had been transported using a
SNMPv2-Trap-PDU, as defined in [RFC3416] - i.e., the
alarmActiveVariableIndex 1 will always be sysUpTime
and alarmActiveVariableIndex 2 will always be
snmpTrapOID.
If the incoming notification is instead an SNMPv1 Trap-PDU and
the value of alarmModelVarbindIndex is 1 or 2, an appropriate
value for sysUpTime.0 or snmpTrapOID.0 shall be determined
by using the rules in section 3.1 of [RFC3584]."
INDEX { alarmListName, alarmActiveIndex,
alarmActiveVariableIndex }
```

**Classification:** MIB object for network management

### Supplementary information

Automatically extracted from IETF [RFC 3877](https://www.rfc-editor.org/rfc/rfc3877.html).

### Child OIDs

- `1.3.6.1.2.1.118.1.2.3.1.1`: `alarmActiveVariableIndex(1)`
- `1.3.6.1.2.1.118.1.2.3.1.2`: `alarmActiveVariableID(2)`
- `1.3.6.1.2.1.118.1.2.3.1.3`: `alarmActiveVariableValueType(3)`
- `1.3.6.1.2.1.118.1.2.3.1.4`: `alarmActiveVariableCounter32Val(4)`
- `1.3.6.1.2.1.118.1.2.3.1.5`: `alarmActiveVariableUnsigned32Val(5)`
- `1.3.6.1.2.1.118.1.2.3.1.6`: `alarmActiveVariableTimeTicksVal(6)`
- `1.3.6.1.2.1.118.1.2.3.1.7`: `alarmActiveVariableInteger32Val(7)`
- `1.3.6.1.2.1.118.1.2.3.1.8`: `alarmActiveVariableOctetStringVal(8)`
- `1.3.6.1.2.1.118.1.2.3.1.9`: `alarmActiveVariableIpAddressVal(9)`
- `1.3.6.1.2.1.118.1.2.3.1.10`: `alarmActiveVariableOidVal(10)`
- `1.3.6.1.2.1.118.1.2.3.1.11`: `alarmActiveVariableCounter64Val(11)`
- `1.3.6.1.2.1.118.1.2.3.1.12`: `alarmActiveVariableOpaqueVal(12)`

### Terms of Use

[Terms of use](https://oid-base.com/disclaimer.htm.md)

**Note to implementers:**: The OID repository is constantly updated but does not necessarily store the latest (or most accurate) version of this formal description. For an implementation, it is recommended to search the web for a more recent description. If this is the case, please update the above description.
