---
oid: "1.3.6.1.2.1.10.200.1.1.1.6"
short-description: "teLinkProtectionType OBJECT-TYPE"
last-modified: "2020-01-22"
parent-oid: "1.3.6.1.2.1.10.200.1.1.1"
---

## OID: `1.3.6.1.2.1.10.200.1.1.1.6`

```asn1
{iso(1) identified-organization(3) dod(6) internet(1) mgmt(2) mib-2(1) transmission(10) teLinkStdMIB(200) teLinkObjects(1) teLinkTable(1) teLinkEntry(1) teLinkProtectionType(6)}
```

### Description

```asn1
teLinkProtectionType OBJECT-TYPE
SYNTAX INTEGER {
extraTraffic(1),
unprotected(2),
shared(3),
dedicated1For1(4),
dedicated1Plus1(5),
enhanced(6)
}
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"This attribute specifies the link protection type of the
TE link. Descriptions of the different protection types can
be found in the 'Routing Extensions in Support of
Generalized Multi-Protocol Label Switching (GMPLS)'
document."
REFERENCE
"OSPF Extensions in Support of Generalized Multi-Protocol
Label Switching (GMPLS), RFC 4203 and
Routing Extensions in Support of Generalized Multi-Protocol
Label Switching (GMPLS), RFC 4202"
```

**Classification:** MIB object for network management

### Supplementary information

Automatically extracted from IETF [RFC 4220](https://www.rfc-editor.org/rfc/rfc4220.html).

### Child OIDs

No child OID

### Terms of Use

[Terms of use](https://oid-base.com/disclaimer.htm.md)

**Note to implementers:**: The OID repository is constantly updated but does not necessarily store the latest (or most accurate) version of this formal description. For an implementation, it is recommended to search the web for a more recent description. If this is the case, please update the above description.
